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SCHED101 - What is Scheduling?



Introduction

Scheduling. 4 classes: 

What is a Schedule?

Schedule Rough-Out.

Schedule Refinement.

Project Tracking.



What is a Schedule?

Objectives include:

Define planning vs. scheduling

Justify need for scheduling 

Introduce project planning process

Introduce Gantt Charts, CPM and PDM methodologies, and other scheduling methodologies





Purpose Behind Scheduling

What is Planning?

Making decisions today with view on tomorrow

80% memory of historic procedures

20% synthesis or creative thought

Consists of estimating, scheduling and project control

Hierarchical, making decisions about what, and how tasks performed

Information search and analysis

Develop, evaluate, and select alternatives

Execution and feedback

Documentation of assumptions, risks, decisions, and analysis of final outcome 

Planning is continuous process required throughout project to monitor and update progress of work





What is a Schedule?

Part of Planning; Plan must come first

Determination of timing and sequence of operations in project

Will result in detection of flaws with Plan requiring modification to Plan; in turn requires modification to Schedule

Systematic and scientific: several well-documented methods exist (Gantt, CPM, ADM, PDM, PERT, etc.)





Benefits of Planning

Provides formalized, systematic learning process

Studies indicate that exceptional planning effort can yield as much as 40% cost savings over reasonable planning (what % cost savings over poor planning?)

Similar studies indicate that better planning (and scheduling) often result in projects meeting or exceeding deadlines

Design workable scheme of tasks to successfully complete project

Control and manage project

Establish accountability





Benefits of Scheduling

Model to predict project completion date, particularly useful for unique (never before performed) projects

Can adjust scope, crew sizes, shifts, or equipment to manipulate duration and readjust completion date

Ability to anticipate and correct potential conflicts (who is delaying what, etc.) is particularly useful in fast track projects (Rapid Application Development)

Significant part of Planning process involves learning from history – thus it follows that historical snapshot of project cycle (schedule) is significant input for subsequent project cycles

Dollar loaded schedules assist in cash flow planning (esp. for resource intensive projects)

As project plans become more complex, need for critical path method schedules increases to plan and track project details

Can effectively mitigate impact of changes mid-stream by testing scenarios to arrive at best alternative

Used to measure delay and time extensions



�The Scheduler

Must pull together data from all project participants (team members, organizations, users, etc.)

Refines the data, and removes bias

Groups the data

Develops comprehensive and coordinated plan represented as schedule





Managing Your Project

What is Project Management?

Planning, organizing, and managing of tasks and resources to accomplish defined objective

Break projects into easily manageable tasks

Schedule the tasks

Track the performance of tasks as work progresses



PM Answers These Questions

What  is to be done?

Who or what will complete the task?

When must it be done?

How much will it cost?

What happens if work isn’t completed on time?





Three Phases of Project Management

Planning project and creating schedule: define tasks, durations, relationships, and resources.

Managing changes:  begins once project baseline is saved, and ends when project is completed.  Tracking and adjusting schedule to best accommodate changes.

Communicating project information:  Communicate project information to clients, project staff, and management.  MS Project provides excellent medium to communicate reports, charts, and graphs.



�Gantt (Bar) Charts

What is a Gantt Chart?

Most frequently used schedule in most industries (also known as “bar charts”)

Created by Henry L. Gantt during World War I

List of Activities in vertical column with Time in horizontal scale

Task start and finish dates, and duration indicated by position of bars in each row

Bar does *not* indicate work will proceed continuously from start to finish – break such a task into two or more separate tasks

Bar charts are typically high-level summary activities, not as detailed as CPM schedules

Typically contain no more than 30-40 activities (max of 100)

Can show anticipated/actual cash flows, anticipated/actual manpower





Benefits of Gantt Chart

Simplest form of schedule to read and interpret

Easy to create

Readily communicates results of a network diagram

Repititious schedules in bar chart format require far less maintenance than CPM schedules





Disadvantages of Gantt Chart

Cannot depict intricacies of multiple activity interaction (relationships not shown)

Simplicity reduces effectiveness and accuracy on large projects with many tasks

Accuracy is limited because task interdependencies are not tracked

Too easy to create, thus can produce unrealistic schedules

Too easy to start from end date, and spread out bars to fit time allotted with unrealistic sequences, constraints, and durations

Scheduler’s design logic (relationships) is not readily apparent, thus tracking change impact is difficult





Size Workarounds

Can use partial schedules (2 week look-ahead schedule) to eliminate complexity of larger schedule

Can use sub-schedules plugged into rolled up summary bars on main schedule





PERT

Definition

PERT - Program Evaluation Review Technique

During 1950s, Lockheed created PERT scheduling method for Polaris Missile Project

Statistical probabilities used to calculate expected durations

Calculated Dur. typically derived from historical activity duration frequency distribution

Where none present, Estimate Dur. = (Pess. Dur. + 4 * Exp. Dur. + Opt. Dur) / 6

MS Project erroneously calls network diagram (flow chart view) a PERT diagram



Benefits of PERT

More accurate on projects where scope or productivity is unknown



Disadvantages of PERT

Additional complexity added (but benefits do not justify it)

We will never use PERT because unnecessary, and value added is too small





Critical Path Method (CPM Schedules)

Introduction

CPM schedules are network schedules

CPM is mathematical model that calculates total duration of project based upon individual durations

CPM identifies which tasks are critical (0 float)

Accuracy is superior to Gantt Charts

PDM, ADM, and PERT are all subtypes of CPM schedules



History

DuPont Corporation and Remington Rand created CPM in 1950s



Benefits of CPM Scheduling

Make job coordination easier

Reveals whether manager understands the project

Reveals whether scheduler understands the project

Gantt has no depth, thus smaller activities are discovered at last minute or even omitted altogether whereas CPM scheduling forces these details to surface much sooner



�Definitions

Activities:  single work step with recognizable beginning and end (task)

Work Breakdown Structure:  hierarchical system which subdivides larger elements of project into smaller pieces

Duration:  time required to complete activity

Logic:  order in which activities accomplished

Logic Diagram:  also known as “network diagram”

Critical Path:  sequential combination of activities and relationships from project start to finish that requires the longest time to complete.

Critical Activities:  any activity with 0d float; any delay of these activities delays the project





Variations in Planning / Scheduling

No two schedules for same project are same since schedulers break down differently

Personal Causes:  personality, methods and techniques, preference, other project schedules, other company commitments, how you predict

Project Related Causes:  shifting parameters, project complexity, specifications (N/A), project personnel / subcontractor time requirements, restrictive relationships, environment

Unpredictable Causes:  third party product problems, delays to third party product releases, Windows bugs, development language bugs, labor market





Determining Work Breakdown Structure

WBS groups activities

All projects need to be organized and broken down into “work packages” or major elements

Used early in project as first step in planning

Requires use of codes to identify each sub-part

Look for multiple breakdowns: physical and management (e.g.: phase, location in product, milestone codes, etc.)

Must be a master WBS Schedule for control

Activity size should be small enough to control work, but large enough so not unnecessarily complicate or lengthen schedule



�Benefits of WBS

Organize and systematically break down total scope of work

Determine major framework of schedule

Control look of network diagram

Simplify complex schedules (roll-ups will be meaningful)

Provide more controllable size schedule (again, roll-up to appropriate level complexity)

Enables concentration on problem within schedule (sort by code)

Used during scheduling phase to provide basis for milestone schedule and simplify computation

Used during project tracking phase to manage project, display specific activities and fragnets to others, to extract problem areas only, etc.





Determining Durations

Duration is time expected to complete activity

Duration should be uninterrupted; time lapses should force activity to be split into two separate activities

Duration “granularity” should be in days

Durations exceeding two weeks are a risk; break down the activity into multiple smaller pieces





Duration Consists of

Estimate:  Man hours, special hardware/software setup, crew size, function points (scope)

Learning Curve:  Has crew ever performed this type of work before?  If so, how experienced?

Guess:  Portion of Duration estimate is always just a gut-level guess

Risk:  Add in additional time to mitigate Risk, as needed (e.g.: double or triple duration for risky activities, or activities with drop dead deadlines)

Mobilization:  Do not forget to add in setup / startup time for each activity

Cost:  If variable cost and cheaper to get activity done in short amount of time, then scheduler attempt to shorten duration.





Determining Resources

Cash:  Monitoring cashflow is a big reason behind cost-loaded schedules

Manpower:  Throughout project cycle, there will be up and down periods for staffing.  Schedule permits manager to level off these high and low periods of activity.

Materials:  Manage CD shipments, burning, packaging, and other material deliveries

Equipment:  Manage timely delivery of support equipment (scanners, faster computers, modems, etc.)

Time:  Be sure time is not being squandered 





PRECEDENCE DIAGRAMMING METHOD (PDM)

Introduction

Prof. John W. Fondahl of Stanford University presented PDM technique in 1961

Replaced ADM (Arrow Diagramming Method) – not discussed in this course

Boxes represent activities

Arrows represent relationships





Benefits of PDM

Simpler way of indicating complex logical relationships among project activities, particularly when concurrences exist between activities

Smaller than Gannt Charts (and I-J networks) – not applicable to MS Project though

Able to model overlapping relationships among activities without having to split them (using lag, lead times)





PDM Logical Relationships

PDM uses four logical relationships between activities:

Finish-to-Start (FS): Finish of predecessor is linked to start of successor activity. Recommend that you keep schedule simple and use only FS relationships (exclude other three).

Start-to-Start (SS): Start of predecessor is linked to start of successor activity

Finish-to-Finish (FF):  Successor must finish simultaneous with predecessor

Start-to-Finish (SF):  Successor must finish before predecessor can start





Lag:

No Lag:  Activity can begin right away.  Recommend that you keep your schedules simple by always using “No Lag”.

Positive Lag:  Activity can not begin until specified elapsed time has passed.  Example would be start debugging activity concurrent with testing, but a positive lag of 1 or 2 days.

Negative Lag:  Activity must begin specified elapsed time before predecessor.  Also known as lead time.

Lag will add element of uncertainty because now 3 instead of 2 elements necessary for scheduling logic (duration and sequence, plus lag assumption)





Relationship Rules

Try to use only default FS relationships

Try to avoid the use of Lag

Only use predecessor relationships (using successors is inconsistent and unnecessary)

Only include predecessor relationships that are “DRIVING” activities (those that are directly inline)

Minimize the number of relationships used…but be sure that every activity has a predecessor and implied successor (another activity with it as predecessor)





Logic Loops

Situation where logic flow reverses back to previous node

Avoid accidentally building in logic loops, else MS Project will not calculate schedule dates

Step 1 safeguard is to avoid using anything other than Finish-Start relationships unless mandatory

Step 2 safeguard (MP hard knocks) make ample use of intermediary milestones – wrap up all relationships into milestones, then roll milestones together for smooth logic





Dangling Activities:

Also known as open ends

Good scheduling practice mandates that every activity have a predecessor; dangling activities are considered poor scheduling practice

Start activity is only exception, and it is permitted to remain without predecessor because start date can float, and no predecessor can exist

Dangling activities result in logic errors due to omission

Can result in inaccurate critical paths (since relationships not factored in)

Can result in inability to measure impact of changes (no project delay will be visible)

Can result in poor communication of scheduler’s and management’s plan



�Analyzing the PDM Network

The Forward Pass

Calculations to determine early start, early finish times, and project duration (start at first activity and work forwards)

Activity’s early start (ES) time is equal to predecessor’s early finish (EF) time plus any lag time

Note that where there are multiple predecessors, the ES is equal to the largest ES as calculated from each of the predecessors

Activity’s EF time is equal to its ES time plus its duration





The Backward Pass

Calculations to determine late start and late finish times (start at ending activity and work backwards)

Activity’s late finish (LF) time is equal to successor’s late start (LS) time minus any lag time

Note that where there are multiple successors, the LF is equal to the largest LS as calculated from each of the successors

Activity’s LS time is equal to its LF time minus its duration





Sample Calculation

Review pp 109-111





Float

Measure how much an activity can be delayed without delaying project completion date

Leeway (flexibility) in schedule

Types: Total float, start float, and finish float…we will only worry about total float

Delay can occur *without* impacting project completion date

Internal to fragnet

Often shared across multiple activities, thus if anyone in chain burns up float, will unethically deprive others down the chain

Critical activities have *no* float





Critical Path

Longest pathway through schedule from start to finish

All critical path activities will have same early and late start dates

All critical path activities will have 0 total float

Any slip in finish date of a critical path activity *will* slip the scheduled completion date

Rule of Thumb: 20% of activities will be critical





Project Scheduling Methods

Waterfall Method

Best known method, traditional

Successfully used for decades in construction, manufacturing and other industries

Frequently maligned (often unjustifiably)

Project is Planned so that Requirements and Functional Spec detailed out, Designed so that Design Spec and Test Plan / Spec generated, Developed and Tested, and finally Stabilized after which product is released

Majority of communication between functional groups (program management, development, testing, etc.) done through documentation

Sometimes too much documentation, sometimes too little documentation, and occasionally get the right amount of documentation

Outcome of project heavily dependent upon how well groups at each stage understand what is communicated to them and how well they communicate to next group down line

Good method for all releases following original release

Bad method for all releases where neither customer nor development team (Dev, Test, PM) really understand what is needed at outset because best guess will become application design

Bad method because forces design and functionality decisions to be made up front, when development team least understands the product, technology, etc.

If development team (dev., testing, and proj. mgmt) does an inadequate job during planning and design, then this method can be very risky





Incremental Prototyping Method

Also known as “spiral methodology”

Go through design, development, and testing cycles many times on path to final product

Development team (Dev, Test, PM, and customer) meet once or twice a week to design and modify prototypes of features of application

Prototypes evolve into final product

Majority communication occurs in design meetings, where all functions scrutinized

Prototype itself serves as Functional Spec

Design is documented once prototype stabilizes

Physical architecture determined up front – modifying prototype for technology (architecture) and features simultaneously would be extremely expensive in time and effort

Change does not have as severe an impact on prototyping method as it does with waterfall method

Danger of run-away projects that never complete, just continue patching over patches

Mandatory that developers fix bugs immediately, else risk run-away projects if delay bug fixes using this model

Architecture must be thoroughly designed else core is unstable and adding new features becomes risky (note evolutionary model only specifies addition of new features over time, *NOT* changes to architecture)

Early on, testing must thoroughly test the app core, before new features are added in…





Time Boxing Method

Built on top of incremental prototyping method

Determine up front the resources to be used, and the deadline

Modify scope (not resources) to deliver project at appropriate point – controls runaway project risk

Use on projects where features not nailed down up front





Analysis

Both the Waterfall Method, and the Time-Boxing Method can be effectively used in a software project

Use the Waterfall Method on projects where details can be established up front

Use the Time Boxing Method on projects where can not reasonably plan and design project in advance, but must do so as project evolves



�Milestones



Milestones

Definition:  milestones are a reference point marking a major event in a project

Milestones used as checkpoints to monitor project’s progress

Development team should define milestones during planning phase

Some general milestones include: completion of phases of work, meeting that must occur, approval that must be received, start of significant phase of work, etc.

Some specific “major” milestones include: project startup, planning phase complete, design phase complete, development phase complete, release to manufacturing, etc.

Scheduler uses milestones on the schedule to manage the project





Interim Milestones

Virtually identical to milestones, “interim” prefix denotes subordination to higher-level milestones

Interim milestones are sub-level milestones that indicate progress within a frag-net

Typical “interim” milestones include code complete, entry to alpha, alpha complete, entry to beta, beta complete, etc.

Add these in to track feature completion, or other moderately important issues





Milestone Exit Criteria

Exit criteria consists of the deliverables that must be completed for the milestone to be marked as completed on schedule

Development team should establish exit criteria for every milestone up front during the planning phase

Phase Summary Reports (a.k.a.: Exit Reports or Certification Reports) are an example of exit criteria that should be done for major milestones (esp. drop dead milestones)



�SCHED101 - Quiz



What is the difference between planning and scheduling?��

Give three reasons why planning is important:�a)�b)�c)�

Give three reasons why scheduling is important:�a)�b)�c)�

Define the role Project Management plays in the execution of a project.���

Why is a CPM (PERT, PDM, ADM) chart superior to a Gantt chart?���

What is a Work Breakdown Structure?  Is it flexible?  When should you develop a WBS?�1)��2)��3)�

What is Duration?���

Discuss relationships, lag, and dangling activities.  (Hint: recommended never use lag, and always use FS.)�

�Discuss the forward pass, backward pass, and float.����

Define the Critical Path.  What is the significance of float in relation to the Critical Path?�1)��2)�

Define the three methods or approaches to scheduling: waterfall, incremental prototyping, and time boxing.  Weigh the advantages and disadvantages of each.���

What is a milestone and why is it important?���

�SCHED102 - Schedule Rough-Out



Schedule Development Process



Scheduling Phases

Scheduling can be broken down into four major phases.  Class #2 will be spent on Planning Phase + Schedule Rough-Out in the notes below.  (Class #3 will be spend on Scheduling Refinement and Updating Phase in other notes.)�

Planning, Building Infrastructure:  Investigation, create WBS, create responsibility codes, establish numbering system, list activities, and list milestones

Scheduling Rough-Out:  Determine durations, locate restraints

Schedule Refinement:  Revise & compress, agree & approve, finalize, archive baseline, publish, distribute

Updating:  Investigate (COP), update data, publish changes, identifying problems, distribute





Introduction

Producing good schedule requires good people skills

Understanding of software design and development

Available time and desire to schedule

Understanding of network scheduling techniques (mathematical model)

If CPM fails to accurately portray the process, schedule will be ignored, and valuable management tool will not be used

More complex a project is, the bigger the need for structured approach at developing original schedule

Schedule is most important document created during development process





Planning, Investigation

Understand the Requirements, Functional Spec, Design Spec, and other documents

Be sure to follow company Schedule Formatting Specifications

Study existing project schedules

Study external white papers or textbooks that contain ideas

Ask many questions

Interview development team members and product management personnel

Learn high level groupings, activities, and planned sequences

Scheduler’s people skills are critical here

Scheduler must exercise humility, salesmanship, and care when collecting ideas and recommending approaches in schedule

Emphasize that scheduler’s involvement is merely to coordinate and integrate all ideas, *NOT* to force a schedule—a schedule not used is worse than no schedule (discredits the process, wastes time, etc.)�



Planning, Build WBS Infrastructure

Create Work Breakdown Structure (optional) to organize activities in hierarchical format (automatic in MS Project).   Divide project into Subnetworks.�A typical WBS list of fragnets (subnetworks) would look something like this:

Project Startup

Project Wrap-Up

Planning

Design

Development

Stabilization

Alpha Test

Beta Test

Production

…





Planning, Responsibility Codes

Create responsibility codes in table.  Include 2 or 3 digit initials plus resource name (JD for John Doe), and crew plus crew abbreviation (Dev for Development)�

Planning, Create Numbering System

Establish all special numbering systems and breakdown codes.  Apply to WBS list.  Codes include accounting or costing codes, mapping back to specs, etc.

��Planning, Activities List

Build Activities list out fragnet by fragnet from WBS.  �A typical list of high-level activities would look something like this:



Planning

Vision Statement (Goals)

Requirements Document

Functional Specification

Content Specification?

Conversion / Upgrade Plan��Design

Design Specification (Data + Inputs + Output Layouts)

Architecture (Data + Process Overview) Designed

Technical Learning / Training (Oracle, C++, etc.)

Design & Build Prototype (Hardware + Software)

Test Prototype

Review Prototype

R&D Third Party Component(s)

Development Document

Test Schedule

Development Schedule

Project Baseline Schedule (Test + Dev + PM)

Test Plan

Test Spec

Create Test Cases, Backend

Create Test Cases, GUI

Create Test Cases, Performance

Create Test Cases, …��Development

Data Cleanup / Maintenance

Data Conversion / Upgrade

Create Test Cases, Features

Execute Test Cases, Backend

Execute Test Cases, GUI

Execute Test Cases, Performance

Execute Test Cases, …

Create Test Data

Fix Existing Bugs?

Develop Features 001

Develop Features 002

Develop Features nnn

Unit Test Features 001

Unit Test Features 002

Unit Test Features nnn

Execute Test Cases, Feature 001

Execute Test Cases, Feature 002

Execute Test Cases, Feature nnn

Debug Feature 001

Debug Feature 002

Debug Feature nnn

User’s Guide(s)

Operator’s Guide(s)

Programmer’s Guide(s) (Adhoc Tools)

Training Guide

Help Files

Marketing Preview(s)

Alpha Test Stage

Bug Fixes, Alpha��Stabilization

Beta Test Stage

Final Inhouse Test Cycle

Bug Fixes, Beta + FITC

Milestone Completion Reports

Test Release (Final) Report

Gold CD

User Acceptance

Burn Production CDs

Ship Product

New Product Training

Project Post Mortem





�Planning, Milestone List

Build milestone list out fragnet by fragnet.  These milestones become the control points from which managers can assess project status.  �A typical list of milestones would look something like this (items with ? are optional):

Planning

Project Start

Requirements Complete

Planning Specifications Complete

Planning Complete��Design

Learning / Training Complete

R&D Complete

Design Specification Complete

Prototype Sign-off

Feature Freeze

Test Planning Complete

Project Schedules Complete

Design Complete

�Development

Architecture Freeze

Structured Test Cases Complete

Feature 001 Complete

Feature 002 Complete

Feature nnn Complete

Build 001 Drop?

Feature 003 Complete

Feature 004 Complete

Feature nnn Complete

Triage 001?

Build 002 Drop?

Triage 002?

Build nnn Drop?

Triage nnn?

Milestone Release Candidate 1

Milestone Release Candidate 2

Milestone Release Candidate 3

Preliminary Test Cases Complete

Level 1 First Test Pass Complete

Level 2 First Test Pass Complete

Level 3 First Test Pass Complete

Level 4 First Test Pass Complete

Level 5 First Test Pass Complete

Code Freeze

Zero Open Sev. 1/2 Achieved

Alpha Testing Complete

Development Complete��Stabilization

Zero Open Priority 1/2 Achieved

Beta Testing Complete

Zero Defects Achieved

Code Complete

Gold CD Tests Complete

Product Sign-Off Achieved

Release to Manufacturing

Training Preparations Complete

CD Archive Complete

Post Mortem Complete

Project Complete

Drop Dead Completion (hard coded date from upper management)��

Scheduling Rough-Out, Durations

Determining durations was discussed in Week #1 Course Notes.



Scheduling Rough-Out, Locate Restraints

Determining restraints were discussed in Week #1 Course Notes.







�Getting a Quick Start with MS Project

Creating a New Schedule

Run MS Project

Click “Start A New Project” button

Select “File” > “Summary Info” menu item

Enter date you want project to begin in “Start Date” textbox

Enter general comments about project

Enter Document Tab info: Project Title, Subject, Author, Company, Manager, Keywords, and additional Comments





Introducing MS Project Gantt Chart

Default MS Project view is Gantt Chart (UG, pg 6)

Notice table of task information on left side of screen

Notice bar chart (Gantt) on the right side of screen

Notice Summary task has sub components in a fragnet (UG pg 7)

Notice Subtasks to Summary task (parts of the fragnet)

Notice duration listed in days

Notice assigned resources





Entering Tasks in the Schedule

First step is to enter tasks into task information grid

It is best to enter tasks in the approximate order scheduler believes they will occur

You will come back later and link all tasks together (predecessor column) thus previous line is important

MS Project automatically assigns default duration of one day (1d)

You can add, delete, combine, break apart, or otherwise alter tasks as needed (easily)

Edits are made by selecting a cell of the grid, and simply typing in the text you want

Deletes are made by pressing the delete key, or choosing delete from the edit menu, or right mouse-clicking and selecting delete from popup





Entering Durations

Estimate how long task will take to perform (using methodologies previously discussed)

MS Projects takes into account weekends and holidays when scheduling, thus you just enter duration in working days – not calendar days

MS Project default calendar defines work week as M-F 8:00am-5:00pm

Duration field format is a number follwed by a letter indicating unit of measure

Available units are days (d), weeks (w), hours (h), and minutes (m)

For our scheduling purposes, 95% of tasks will be measured in days – hours an minutes are far to detailed a granularity; whereas weeks are too broadly defined and should be broken down into several smaller tasks measured in days

A task with a duration of zero (0d, 0w, etc.) is treated as a milestone

Milestones are used to measure progress of project (see previous Class Notes on milestones)

To alter durations, select the duration field, type in a number and duration unit abbreviation, then press <Enter>





Getting Organized with Outlining

Use MS Project outlining functionality to simulate a true Work Breakdown Structure (Project even has military index field titled WBS!)

Arrange the tasks in hierarchical structure that delineates subtasks from summary tasks

Summary tasks clearly identify fragnets which can be major phases of your project, significant work packages, etc.

Easy to roll-up reports and Gantt Charts by Summary Tasks for easier viewing down the road

Tip: Place milestones as exit checkpoints to every summary task / fragnet – facillitates better project control

To demote a task (make into subtask), press the toolbar button for indentation “->”

To promote a task (make into summary task), press toolbar button for promotion “<-“

Note: To quickly demote or promote tasks, position mousepointer over first letter of taskname, and when mousepointer changes to “<->” shape, click and drag to indent or outdent

Note: You can add WBS military index codes, +/- symbols, and other outline options by selecting “Tools” -> “Options”, then the Outline Options tab

Note:  The ++ button expands all hidden tasks, and the – button hides all sub-tasks, leaving only the level 1 summary tasks





Linking Tasks

Once tasks entered and grouped into fragnets via outlining, next step is to sequence the tasks with relationships, and determine length of project

To create a task relationship, select the tasks you want to link (highlight rows), and click the link tasks button on toolbar (icon = chainlinks)

To remove a task relationship, select the tasks you want to unlink (highlight rows), and click the unlink tasks button on toolbar (icon = single broken chain link)

Alternative creation / removal method is to alter the contents of predecessor column

Tip: Always link together activities within a fragnet (subtasks under same summary task)

Tip: Always be sure subtasks under same summary task eventually link in to summary task close-out milestone

Tip: Always be sure that subsequent summary task has predecessor set to previous summary task’s close-out milestone (do not link summary tasks to subtasks)

Tip: Always use predecessors, and never use successors since same relationship can be created with predecessor – keeps the schedule simpler and easier to understand

Note that the toolbar buttons only assign F-S relationships, and no lag is ever assigned.  Thus, to assign lag, or use S-S, S-F, or F-F relationships, you must alter contents of predecessor field





Assigning People to Tasks

To assign a resource to a task, click Resource Assignment button on toolbar (icon = people’s heads), enter a resource name into the name field, and click Assign

To alter resource information, double-click the resource name in the Resource Assignment window (UG pg. 17), and the Resource Information window will popup (you can change standard and overtime rates, initials, calendar, group, code, etc.

Tip: Only assign subtasks, *not* summary tasks a Resource because it gets double-counted in the Resource rollup views if a person is assigned at the summary level

Note: Resources can be people or equipment to MS Project





Checking Your Schedule

Now that your schedule has been roughed out, it is time to evaluate the schedule

One of first checks is to find out when project will be finished

To lookup project finish date, select “File” -> “Summary Info” menu item, and click Project tab.  There you will see (calculated) Finish Date

To view the entire project on gantt chart, select “View” -> “Zoom” menu, then click Entire Project option button, and click OK button to apply (UG pg 19)



Formatting the Gantt Chart

You can alter formatting of virtually all objects in Project by simply highlighting it, or double-clicking it, and then applying changes

Some typical changes include bold, italic, underline, color, and font changes to text

Other typical changes include the timeline formatting (units in weeks, days, months…), color, size, shape, and any accompanying text to different bar types in gantt, etc.

Tip: Make entire row italics for all milestones to emphasize their significance in managing project

Tip: Do not use underlining or bold text.  Bold is default for summary tasks, so making subtasks bold is confusing.  Underlining is partially obscured by gridlines.





Printing Your Schedule

Once your preliminary roughed-out schedule is completed, it is time to print a hard copy for easier viewing

To preview or print, select “File” -> “Print” or select the print preview button on toolbar

Note that there are many options to aid in formatting your output at the pre-print stage

Tip: If you have a postscript printer, you can fit your schedule to the page





Saving Your Work and Quitting

It is a good idea to periodically save your work to guard against loss

To save a new project file, click the Save button on toolbar (icon = 3.5” floppy)

When prompted, select Save *Without* Baseline (because baseline will be saved after next course’s Schedule Refinements have been completed), enter a filename, and click OK





Creating and Organizing a Schedule



Useful Task and Duration Details

Outlining can go to a maximum depth of 10 levels

To schedule a specific task over the weekend or a holiday, prefix the duration unit abbreviation with the elapsed character ‘e’.  Thus, five elapsed days (concurrent and ignoring holidays and weekends) would be represented as ‘5ed’

To change a task to a milestone, enter a duration of ‘0d’; enter an actual duration (number > 0) to change the milestone back into a task

To enter a recurring task (like a meeting), choose “Insert” -> “Insert Recurring Task”, and fill out the form (UG, pg. 40)

To quickly change a duration from the Gantt Chart, you can use the mouse to drag the bar length to the right or left to increase or decrease duration (mousepointer changes to “|->”)

You can easily rearrange individual or groups of tasks by highlighting the task(s), then dragging and dropping it into the new location

Note: When you move a single summary task, all of its associated sub-tasks will move too





Sorting Tasks

You can sort your tasks by different columns to emphasize different issues / events

To re-sort the tasks, select “Tools” -> “Sort” and then “By Start Date” or “By Finish Date”, etc.

You can specify a user-defined sort (right click, or “Sort By…” using menu) to enter up to three levels of sorting, plus direction (ascending or descending)

Note: Be sure to *uncheck* “Permanently Renumber Tasks” else you will mess up the Task ID numbers.

Note: the default for sorting is to move summary tasks as a block with sub-tasks when sorting – thus the sub-tasks are not sorted…flip off the option in the “Sort By…” dialog to prevent this default condition (if you want)





Task Constraints

MS Project automatically calculates start and finish dates for you; however, you may want some tasks to be constrained to start or finish on specific dates – hence the use of Task Constraints

Typical constraints include: As Soon As Possible (ASAP), As Late As Possible (ALAP), Finish No Earlier Than (FNET), Start No Earlier Than (SNET), Finish No Later Than (FNLT), and Start No Later Than (SNLT).

Tip: Do not ever use the constraints Must Finish On (MFO) or Must Start On (MSO) because they will lead to miscommunication (since relationship is implied thereby hidded to those viewing schedule)

Although I recommend against the use of constraints (unless have a good reason), some typical uses might include setting the finish or shipping date to Finish No Later Than, or setting a Start No Earlier Than milestone to any known fixed date such as the end of a quarter for data shipments.

Tip: For the few times that you do you constraints, ALWAYS link them to a milestone with an obvious name denoting the existence of the time constraint to the schedule reader – do not link to tasks



�SCHED102 - Quiz

Answer the following questions by building a single MS Project schedule:



Generate an Activity List containing at least 40 tasks (hint: fill in task column)��

Insert at least 15 milestones into your Activity List (hint: add new tasks with 0 duration)��

Organize the Activity List by creating Summary Tasks and sub-tasks out of the activities listed (hint: promote and demote activities accordingly)��

Assign resources to all sub-tasks��

Determine and enter Durations for every activity (hint: typically would ask assigned resource to estimate duration)�

Add relationship restraints into schedule (hint: assign predecessors for all tasks)���

Be sure that the last sub-task for each summary task is a milestone.�Check that all “sibling” sub-tasks are indirectly or directly tied into these milestones to prevent dangling tasks��

Print your schedule and take it into class for review�





�SCHED103 - Refinement & Tracking



Part 1: Schedule Refinements

The purpose of Schedule Refinements is to compress or crash your schedule timespan, and also to clean up the formatting.



Formatting the Schedule

More on Relationships

MS Project supports Finish-to-Start (FS), Start-to-Start (SS), Finish-to-Finish (FF), and Start-to-Finish (SF)

Tip: You can get by with using *only* FS relationships to keep your schedule simple.  To simulate an SS relationship, make two FS relationships to the two Activities that otherwise would be 1 FS + 1 SS relationship.  You can simulate an FF by making both activities wrap into the same FS activity.  The logic is much more readable if you stick to FS relationships only!

Overlapping and Delaying tasks can be accomplished with the use of lead or lag time.  To enter lead or lag (not recommended), append the following formats:  +1d, -2d, +25% to the appropriate predecessor value

Task Constraints should be avoided





Formatting the Task List

Standard Project fields in the task list should include the defaults (Task Name, Duration, Predecessors, and Resource Name), plus Actual Start, Actual Finish, and Percent Complete.

Other optional fields include Cost and Change Order Proposal (COP).

To add fields, highlight the column to the right of where you want new task inserted, and press the Insert key or select menu item “Insert Column”.  Then, select the field name to insert, enter an abbreviation and click OK.





Formatting the Gantt Chart

The data date line (current date) should be more obvious.  �To change the line, right click anywhere in the whitespace of the Gantt Chart, select “gridlines…” from the popup, and change the “Current Date” line type to “dashed” and the color to “red”.

The critical path activities should stand out.�To alter bar formatting of critical path activities, double-click anywhere in the whitespace of the Gantt Chart to bring up bar styles dialog.  Click row beneath Task in Name column,  and choose Insert Row button.  Type “Critical” for name, and again for Show For column.  Click enter.  On tab labeled “Bars”, select red for color, and the bar style with vertical lines (instead of default solid fill style).  Click Ok.

Baseline Activities should be visible.�To add in baseline activities, double-click anywhere in the whitespace of the Gantt Chart to bring up bar styles dialog.  Click row beneath Task Name column, and choose Insert Row button.  Type “Baseline1” for name, and enter “Start1” and “Finish1” for values in respective textboxes.  (Suggestion: select lower half as bar style for these baseline activities, then modify normal activities to show upper half only.)

The Gantt Chart Wizard can be used to alter settings easily.�To run the wizard, click the Gantt Chart Wizard button (icon = wand with bars).  Then make your selections for formatting the output.





Evaluating and Adjusting the Schedule

General Strategies for Shortening (Crashing) the Schedule

Overlap:  Change task relationships to allow more tasks to overlap (multiple tasks start simultaneously), rather than strictly sequential

Use Float:  Start the task earlier if time permits.  Front loading will pay off in a non-linear fashion at the end of the project (I experienced this in school).

Scope:  Reduce scope of project by combining or reducing number of tasks – elimination or deferral to subsequent release of functionality is a classic 

Duration:  Realistically reduce durations by limiting task scope, or using more efficient resource, etc.  Change the methodology to alter duration.

Calendar:  Increase available working time by changing project calendar (work more hours per day, more days per week)

Breakdown:  Breakdown large tasks into summary tasks with subtasks to pull-in the subtasks in parallel for simultaneous execution

Milestone Check:  Be certain that no milestone exit criteria are artificially holding up schedule (logic error indicates invalid sequence of events leading to milestone that improperly holds up subsequent tasks)

Resources: Throw more resources at task to complete sooner, or use overtime

Lead / Lag Time:  Analyze all Finish-to-Start relationships to see if you can overlap them for simultaneous execution…a simple double FS relationship from the same parent task to the two children tasks are sufficient substitute to simulate SS, or FS with lead/lag for our current level of sophistication.

Constraints:  If you did happen to use any constraints (not recommended), then be sure to go back through and verify that there are none that are erroneously holding up the project

Administrative Overhead:  Look if too many reports, meetings and other non-essential support activities are tying up resources…be careful not to completely eliminate because some level is always appropriate





Shortening the Schedule by Changing the Critical Path

Most obvious way to shorten length of schedule is to shorten the critical path by deleting, combining, or simultaneously starting tasks

Also most difficult, because you will be attempting to remove or scale back the tasks that are not absolutely necessary to project completion (but aren’t all tasks necessary?  No, some more than others hence the dilemna)

Break all large critical tasks down into a summary task with subtasks to maintain better control over progress, and to look for opportunities for improvement





Caution

When crashing the schedule, be sure to:

Be Sparing:  Do not crash every activity as that will harm morale and make schedule meaningless (not true estimates of time)

Be Realistic:  Every task can only be shortened so much (% varies), do not over do it

Risk:  Recognize that crashing a task decreases accuracy in duration estimate

Quality:  Always try to minimize quality reductions when crashing activity

Prioritize:  Crash activities such that those with best ratio of big gain in time for smallest resource impact are crashed first

Avoid Non-Critical: tasks because by definition, they have float thus crashing them will not reduce project completion time one bit





Input

At this stage, it is essential that the scheduler receive substantial input from other project team members

Meetings can be held to look for methods to crash the schedule using techniques above

Meetings can be held to look for problems or delays in the schedule



�Float Analysis

Excessive float on various activities typically indicates poor scheduling with insufficient relationships built into the work sequence.  This indicates lax attitude toward project schedule.

Opposite is too little float resulting in excessive number of critical paths.  This can  indicate manipulation for delay claims.

Float Analysis performed mathematically by summing float for each activity, and dividing by number of activities resulting in average float.  

Average Float meaningless unless used as benchmark to compare against other project schedules



Resource Leveling

DO NOT USE RESOURCE LEVELING.  It leads to the introduction of constraints and other hidden “relationships” that make reading your schedule very difficult.





Printing the Schedule

Gantt Charts

Most common form of output

List of project phases including hierarchy of activities (summary and sub-tasks), durations, resource assignments, etc.

Bar chart representation of activities against time

Task relationships are now shown on MS Project Gantt Charts, making them CPM diagrams as well as the simpler Gantt Charts they resemble

Start and Finish dates

Percent Completion on each task





Calendar View

Very simple to understand (familiar calendar format with activities spanning date boxes)

Only task name and duration listed

Time relationship displayed

Inappropriate for projects with more than 25-30 activities per month, esp. if exceed 3-4 activities per day



�Project Summary Report

High level overview

Contains number of tasks, number of hours in project, number of resources, total cost (if implemented), project start and finish dates, project duration, etc.

Good for Weekly Management Reports





PERT Chart View

Network diagram containing all activities and the relationships between each

Not very useful other than displaying relationships.  

Better off using Gantt Chart which also indicates time axis.





Resource Report & Weekly To-Do List

List of resources showing tasks to which assigned

Amount of work assigned per week





Who Does What Report

Lists activities to which each resource assigned

Start and finish dates

Additional resource info.





Tasks Starting Soon Report

List of tasks starting within a time period that you specify





Miscellaneous Reports

Weekly Cash Flow Report listing cost of each task per week plus total

Resource Graph showing cumulative cost per resource over life of project

Earned Value report shows list of tasks indicating whether ahead of or behind schedule as compared with actual costs incurred (closest thing to S-curve)



�Printing a Report

To print a report (bit more complex than printing views or Gantt Charts):

Select “View” -> “Reports” menu item

Select type of report to print

Click “Select” button

Select report to print

Click “Print” button from Preview window

Make printing options selections

Choose “OK” button





Page Setup

You can alter the page setup in the following ways:

Change paper size, or page orientation (landscape vs. portrait)

Fit the schedule to specified number of pages (on Postscript printers only)

Adjust the margins

Add borders around every page

Add a header or footer to every page (useful for company logos, etc.)

Insert and remove page breaks

Add a legend to every page

Print only visible columns, or all columns, or only first few columns on every page





Scaling a View Proportionately for Printing

Method #1 for Postscript Printers:

Switch to view to print

Select “File” -> “Page Setup”

Select Page tab

Select “Scaling, Fit To” option

Enter number of pages wide and/or tall for output

Click OK button



Method #2 for all printers (not as elegant)

Select “View” -> “Zoom…” menu item

Select “Entire Project” option (or set reasonable number of days)

Click OK button





�Part 2: Project Tracking

Project Tracking is concerned with updating the schedule as to status changes, and revising the schedule as to initial errors, omissions, and oversights in the schedule design.



Updating, Revising, and Re-Scheduling

What is Updating, Revising, and Re-Scheduling?

Updating: Marking progress on schedule by entering actual numbers  is called “updating” the schedule

Revising: Often, the planned schedule was not correct, thus adjustments to relationship logic, alterations to durations, addition of new activities, etc. must occur

Re-Scheduling:  Much time and effort required to validate actual progress against planned schedule.  Re-scheduling consists of updates plus revisions.





Why Update the Schedule?

Monitor progress and measure impact (improving, getting worse)





Why Revise the Schedule?

Virtually impossible for planned schedule to be precisely followed from start to finish

Changes in scope need to be measured

Unanticipated problems need to be tracked and impact assessed

All of these issues necessitate a schedule “revision” which should be routinely produced





Why Re-Schedule?

Determine project status (ahead of, behind, or on schedule)

Monitor efficiency of tasks and resources

Locate problems faster

Updated schedule is important to all project team members

Distribution of updated and revised schedule is excellent communication tool to keep project team members informed

Those responsible for delays will be identified for further corrective action

Management needs to know so that decisions can be made to get project back in control if necessary (primarily if completion date slips)

Task priorities can be determined by assessing updated schedule’s critical path



�Frequency and Detail of Re-Scheduling

Re-scheduling can occur daily, weekly, bi-monthly, monthly, etc.

Frequency dependent upon size, complexity, and characteristics of project

Recommended frequency is twice a week

Do *NOT* permit updating and revisions to stop completely – if this occurs, then there was no point in having created the schedule in the first place because using an obsolete schedule can negate most of advantage of formalized planning and scheduling

Re-schedule anytime there are significant deviations from planned schedule and publish to communicate the impact

Incomplete updates or revisions have no value (people will use out-of -date content to discredit schedule); thus be certain that when issued, the new schedule is 100% up-to-date

Routinely update percentage complete of tasks





Sources of Update Data

Project meetings should be conducted at least weekly to review project status…including schedule

Review bug counts, test case coverage and execution status, feature completion list and other metrics to confirm level and quality of completion

Incorporate Weekly Status Report information (tailor it to be useful to scheduler also)

Standard correspondence such as email

Milestone completion meetings / reports





Effective Use of Schedules

Introduction

Between good intentions at start of project, and realities of workload as project progresses, schedule often is ignored

As time elapses, may even be ridiculed – considered inaccurate and useless by project personnel

To avoid this, scheduler must constantly search out and obtain involvement from project personnel

To avoid this, scheduler must maintain currency of schedule  with updates and revisions

To avoid this, project management must use and believe in the schedule, referring to it at meetings over and over as revisions come in

When all team members use the schedule, all of benefits mentioned above will occur

“The real benefit of schedules comes in their use to analyze progress and replan the project” - Callahan, pg 235





Developing Baseline Schedule for Fast-Track (Incremental Prototype) Projects

Essential that these schedules be as detailed as possible, despite lack of adequate design documentation

Essential that these schedules be produced and start the updating and revision process as soon as possible

Early and detailed schedules allow project team to study entire project and discover problems long before they occur – when it is cheaper and easier to fix

Do *NOT* set up a framework of summary activities to be expanded later when execution is about to occur…so doing will cause confusion and in-fighting if omissions or scope increase occur (schedule impact can not be accurately measured until entire schedule is built…thus fights as to true impact will ensue)





Multiple Schedules

Do *NOT* prepare multiple schedules on same project

It is very difficult to interface (tie in accurate relationships) multiple schedules

Adjustments in one schedules should impact other schedules, but the impact will not be included because other schedules not adjusted

Schedule’s credibility is at risk when multiple schedules employed





Tracking Progress Using MS Project

Introduction

Tracking project is three-step process:

Create baseline plan

Update schedule routinely

Compare information in updated schedule back against baseline plan





Why Set a Baseline Plan?

Provides benchmark for comparison of costs, work, and scheduled dates as track project progress

Baseline enables tracking, and tracking enables status checks to ensure tasks on schedule, resources completing tasks as assigned, and costs not exceeding budget

Also can save up to five interim “milestone baseline” plans to be used in subsequent project cycles (helps produce more accurate initial baselines)

To set a baseline: Select “Tools” -> “Tracking…”, then choose “Save Baseline”.  Make sure “Entire Project” option button is selection, and click OK button.





Which Information Should I Update?

Actual Start Date:  Update the actual start date of tasks.  It is important to track whether tasks start and finish on time; and these actual dates are critical to that tracking.

Actual Finish Date:  Update the actual finish date of tasks.

Percent Complete:  Update the percentage complete of tasks.  Tasks with small durations (1-2d) do not require this entry.  Tasks that are too large (> 2wks) should be further broken down.  Tasks of moderate duration should have percentage complete tracked.

Miscellaneous:  For detailed tracking, scheduler can update actual costs, and actual resource hours worked…but this is a lot of overhead and is not recommended unless your organization is sophisticated and behind it





Which Information Should I Revise?

You can revise all fields from the original baseline plan.  

Typical fields include modifying the schedule logic by changing predecessors

Alter scheduled start and finish dates as tasks slip

Alter durations as new scope changes, etc. come in

Add or remove activities as needed

Add / alter lead / lag time (not recommended use in first place)

Add / alter constraints (not recommended use in first place)





Change Order Proposals

Tip: I have found it to be very beneficial to track the impact of changes directly on the schedule as “COPnnn: title” activities.

A Change Order Proposal (COP) is notification that a significant cost or schedule impact has occurred as a result of a scope change or other variation from original design

A Change Order is a COP that has been signed off on by senior management



�SCHED103 - Quiz

Answer the following questions by building a single MS Project schedule:



List and define the four types of relationships available for linking tasks.  Discuss which one is primarily used, and why the others should be avoided.  (Hint: mention workarounds.)���

What are three fields you should add to your entry table in the Gantt Chart view?  Why are these important?  (Hint: enable tracking)���

What are two or three important Gantt Chart modifications to make every time you setup a new project?  How do you do it?  (Hint:  bar styles and date line)���

What is “crashing” a schedule?  Discuss the best 3 or 4 methods of shortening the schedule in relation to all other methods.���

Why would you want to print a Gantt Chart?  A Calendar Chart?  A Project Summary Report?  Are there other reports that you find interesting?���

If you do not have a postscript printer, discuss two other methods you can use to size the timeline so that the Gantt Chart is not excessively wide.����

What is the difference between “Updating” and “Revising” a schedule?���

What fields do you use to update your schedule?  What fields do you use to revise your schedule?���

Why would you want to update and revise your schedule?���

How often should you reschedule (update and revise)?���

What is a baseline schedule, why should you use them, and how do you create a baseline snapshot?���

What is a COP?  When should you use them?  How should you display them to emphasize impact?
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